Because most of my games are being made with construct and that requires DIRECTX 9 or above to run them so I decided to put a link to the DIRECTX 10 Download site, enjoy.